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1  Installing Windbag 
 
The installation of the program is in two parts – the installation of the 
trial version of the software and the installation of a user licence. 
 

Installing the trial version 
To install into Windows, simply insert the CD into the CD ROM drive. 
 

Note: if your CD is not set for autorun, double click on “My 
Computer”, then double click on the icon for your CD drive (This 
should display as the Sensory Software symbol) and then double 
click on the Setup icon. 

 
You will see a row of flags, representing the languages available on 
your installation disc.  Select the language that you want by clicking the 
flag.  All messages from then on will appear in that language. 
 
You may install to any drive or directory, but to share resources with 
other Sensory Software programs, it must be installed in the same place.  
If in doubt, just press Enter or click OK at this point. 
 

Installing a user licence 
The program installs as a demonstration version that will run for 60 
days.  After that, you must purchase a licence disk to keep using the 
software.   
 
To install the licence, launch the licence manager from the start menu: 
 
Start Menu > Programs > Sensory Software > Licence Manager 
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Copyright Notice 
 
 
Windbag      © Sensory Software 1999-2005 
 
The following licences are available for the software described in this 
manual: 
 
Single User 
A single user licence allows only the person for whom the program was 
purchased to use it on any computer. 
 
Group Licence 
Copies of a program purchased by an institution, such as a school or 
hospital, may be used on up to 5 computers that are the property of that 
institution and are used only on the premises of the licensee.  Students, 
clients or patients should have their own copy for use on their personal 
computer systems. 
 
Site Licence 
Copies of a program purchased by an institution, such as a school or 
hospital may be used on any computer that is the property of that 
institution and is used only on the premises of the licensee.  Students, 
clients or patients should have their own copy for use on their personal 
computer systems. 
 
Institutions requiring additional licences for multiple users should 
contact their distributor. 
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2 Using Windbag 
Launch Windbag by clicking on Start Menu > Programs > Sensory 
Software > Windbag 3 
 

What Windbag does 
Windbag is a communication program to help people with no speech to 
use a normal PC as a communication aid.  It has the following main 
functions: 
 
A chat window, for immediate speech 
A prediction window, to help you to enter messages more quickly 
A message list, so that useful phrases may be stored and found easily 
 
Windbag can be run with a mouse and keyboard, and also works with 
any alternative input system, such as special keyboards, or on-screen 
keyboards. 
 
The Grid (our on screen keyboard) can be used as an input to Windbag, 
but as some of the functionality of Windbag is already included in The 
Grid, many users of The Grid manage without the extra features of 
Windbag. 
 
We will now look at the main features of Windbag 
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The Chat window 
This is the main window that is used to enter messages, search for 
messages or simply to type and talk.  When Windbag is first installed, 
this will be set to speak each word as you type it, and to repeat the 
whole message when you press the Enter key. 

 
Instead of pressing the 
Enter key, you can click the 

speak button on the toolbar 
 
Your messages will remain on 
the screen, and you can go back 
to a previous message by using 
the arrow keys or by clicking 
with the mouse 
 
 

 
You can speak different parts of your messages by pressing the 
following keys: 
 
CTRL-UP speaks the current sentence 
CTRL-DOWN speaks the current paragraph 
 
You may also speak a highlighted section of text.  Do this either by 
holding down the Shift key while using the cursor keys to move around 
the chat window or by dragging with the left mouse button. 
 
You may then speak the selected text by clicking the speak button in the 
toolbar.  You may also speak it by copying the selected text to the 
Windows clipboard.  This is explained in the section on advanced use of 
the chat window. 

 
You can clear the chat window by pressing F10, or clicking the 
clear button in the toolbar. 
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Speeding up your input 
 
Prediction 
As you type, the prediction window will show suggested words.  If the 
word you want appears, you may select it by pressing the F key next to 
the word, or by clicking on the word. 
 
Users of an on-screen keyboard, such as The Grid, which has its own 
prediction system may prefer to turn off the prediction.  This can be 
done by closing the prediction window by selecting Show Prediction in 
the View menu (ALT-V followed by F) or by clicking the X. 
 
Common words 
You can speak the most common words by using these keys: 

 
\  No 
/ Yes 
[ Please 
] Thank you 
` OK 

 
Abbreviations 
You can create abbreviations to speed up common words or phrases.   
 
Try using the samples provided: 
 
“2sp” and “mn” 
 
Instant messages 

At any time while typing, you can press the = key, or click the 
instant button in the message window toolbar. This will display 

your favourite 26 messages.  You can speak one of them by pressing the 
letter next to the message.  Press Esc if you decide not to speak a 
message after all. 
 
Instant messages are explained more fully in the section on the message 
window. 
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Advanced use of the Chat Window 
 
Saving and loading conversations 

You can save the current contents of the chat window by selecting 
Save from the File menu (ALT-F followed by S) or by clicking 

the save button in the toolbar.  Your chat file will be saved using the 
first few words of the first message.   
 

You can re-load it from disk by selecting Open from the menu 
(ALT-F followed by O) or by clicking the open button in the 

toolbar. 
 
This will bring up a list of saved chat files, showing the first line of 
each.  Select one by highlighting it and clicking OK, or by double 
clicking it, or by selecting with the arrow keys and pressing Enter. 
 
The chat file window also allows you to delete saved chat files that you 
no longer need.  Highlight the chat file you wish to delete using the 
arrow keys or mouse, and delete it by pressing ALT-L or clicking the 
delete button. 
 
Delivering a speech or presentation 
The chat window makes an excellent way to deliver a presentation a 
paragraph at a time, especially for switch users.  Text from any 
Windows word processor may be pasted into the chat window.  It may 
then be edited and saved until needed again.  To read out your 
presentation, set up a cell in The Grid (or other on-screen keyboard 
program) to send CTRL-DOWN.  This will speak a paragraph, and 
advance to the next one with a single selection. 
 
Printing a chat file 

The contents of the chat window may be printed at any time by 
selecting Print from the File menu (ALT-F followed by P) or by 

clicking on the print button in the toolbar 
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The Message Window 
 
Your most commonly used phrases can be ready programmed into 
Windbag, using the message window.   It is ready programmed with 
some sample messages that you can use.  Clear the chat window and 
type just the letter “h” 

 
Notice how the message window 
now shows only those messages 
containing a word beginning 
with “h”. 
 
As you continue to type your 
message, the list will get shorter 
as there are fewer messages that 
match what you have typed. 
 
 

If what you want to say is already in the message list, you do not need to 
finish typing it.  There are three ways to select a message: 
 

• Just keep typing until it is the only message left 
• Click on it with the mouse 
• Press F8 to highlight the message window, and select a message 

with up and down arrow keys. 
 
Speaking the selected message 

You can speak message by pressing CTRL-RIGHT, or by double 
clicking on it, or by selecting it and clicking the speak button in the 

message window toolbar.   
 
Adding new messages  

If the message that you type into the chat window is a new one, 
the message window will not show any messages at all.  If you 

wish to add the new message to the list, press F9, or click the add 
message button in the toolbar. 
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Advanced use of the message list 
 
You can manage your message list by editing or removing messages that 
you no longer need, by re-arranging them, or flagging a request for a 
friend to record them later. 
 
To delete a message 

First select it, then press the delete key, or click the delete button 
in the message window toolbar. 

 
To alter a message 

First select it, then press F11, or right click in the message 
window to bring up the editing window.  Edit the message and 

press Enter or clock the OK button. 
 
To flag a message for recording 

First select it, then press F12, or click the flag for recording button 
in the message window toolbar.  A friend who will record your 

messages will later be able see a list of messages that you have flagged. 
 
Instant Messages 

You will now see that the instant messages are really just the top 
26 messages in the message list.  You may wish to move your 

messages up and down the list so that you can decide which messages 
are in the top 26.  
 
Gapped Message 
A message with the underscore (_) character will have a gap that can be 
filled in when the message is spoken. 
 

Re-ordering your messages 
You can also move messages to make sure that your most frequently 
used ones are near the top of the list, ensuring that the most used 
messages are found first. First select your message with the mouse or 
keyboard. 
 
ALT_UP moves a message up the list 
ALT-DOWN moves a message down the list 
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Using topic files 
 
So far, we have used only one list of messages.  In fact, you can have as 
many as you like; for example one for home, and one for work or 
school. 

 
To show the topic files 
To show all the topic files, select 
Topic files from the View menu 
(ALT-V followed by T).  The 
topic window will then appear 
next to the message list window. 
 
 
 
 

 
To select a topic file 
Press F7 or click in the topic window.  Then use the up and down arrow 
keys to select the topic files.  As each topic file is selected, the message 
list will alter to show messages from that topic file.  Notice that your 
main list of messages is called Favourites. 
 
As you type messages in the chat window, the searching will be done in 
the currently selected topic; however, your instant messages are 
ALWAYS the first 26 in the Favourites list. 
 
Adding and removing topics 
Select Topics from the File Menu (ALT-F followed by T). 
 
A window appears listing the topic files that you have already.  You 
may select one to delete, or add new ones. 
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3 User Preferences 
 
To set up Windbag with your own preferences, call up the User 
Preferences menu (ALT-T followed by P) 
 
A tabbed dialog will appear, allowing you to alter the various settings.  
When you have finished, press the OK button (or the Enter key) to save 
your changes, or Cancel (or the Esc key) to go back to leave your 
settings unchanged. 
 

Multiple  users 
 
You can have more than one user profile.   
 
This will not commonly be needed, but could be useful if you speak 
more than one language, or if the program is used by more than one 
person on the same computer. 
 
To create an additional user, select Choose User File from the menu 
(ALT-T followed by U).  Click the Add User button (ALT-A) and type 
in the mane of the new user profile.  Click OK or pres Enter. 
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The General settings tab 
 

 
 

• The font for the main windows 
• The background colour 
• Turn prediction on or off 
• Hide or show the topic window 
• Select the language 

 
 
Font and background 
This controls the appearance of the text in the main windows, and in the 
prediction and message lists.  It does not affect the main menus and 
dialogue boxes, which are set from the standard Windows Control 
Panel. 
 
Prediction and topic windows 
These tick boxes control will hide or show the prediction and topic 
windows in the same way as the View menu. 
 
Language selection 
This only works if more that one language has been installed.  It sets the 
language used for the menus and prompts, the prediction dictionary and 
the language of the Help files. 
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The Voice settings 
 

 
 

• The name of the voice to use 
• The Pitch  
• The Speed  

 
 
Voice name 
The list will show all compatible voices installed on the computer, 
including many that may have been installed with other software.  You 
may need to licence some voices separately. 
 
Pitch and speed 
Not all voices allow pitch and speed to be changed.  If either of these is 
not available, the slider control will be “greyed out”. 
 
Note about licencing voices 
Some voices need to be licenced before they can be used.  Please refer 
to the instructions that came with the voice CD.  
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The Speech options 
 

 
 

• Automatic speech as you type 
• Automatic clipboard reader 
• Single key messages 

 
 
Automatic speech 
Wind bag may be set to speak each word, or each sentence, or to wait 
for you to tell it to speak when you have finished. 
 
Clipboard reader 
Setting this option makes Windbag speak every time the content of the 
Windows clipboard changes.  This means that you can control the 
speech entirely from another program.   
 
For example, to speak some text from a Word document, you can 
highlight it with the keyboard or mouse and copy it to the clipboard (by 
pressing CTRL-C, or by right clicking or by selecting Copy from the 
Edit menu) and it will instantly speak.  
 
The same technique can be used with any other Windows program that 
allows you to copy text. 
 
If this option is left off, then the current contents of the clipboard may 
be spoken by selecting Speak Clipboard from the Speak menu, or by 
pressing CTRL-LEFT. 
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Dictionary 
 

 
 

• Special Pronunciations 
• Abbreviations 

 
 
There is no real difference between the two uses of the dictionary.  The 
word you type on the right is substituted for the one on the left when it is 
spoken.   
 
Speech Exceptions 
This allows you to set the correct pronunciation for words that have 
irregular spellings, such as proper names or foreign words.  Type the 
normal spelling on the left and the phonetic version on the right. 
 
Abbreviations 
To create your own list of abbreviations, type the abbreviation on the 
left and the word or phrase that you wish to be spoken on the right.  This 
allows a small number of letters and numbers to represent quite long 
phrases if you wish. 
 
Note that the abbreviations may also be used in stored messages. 
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Prediction 
 

 
 

• Prediction Settings 
• Add/Remove vocabulary 

 
 
Automatic learning 
As its name suggests, this adds new words automatically to the 
prediction dictionary.  However, the spelling of all new words is 
checked, so that mistyped words are not added automatically.   
 
Adding and removing words 
If you wish to add a new word that will fails the spell check, such as a 
name or a specialised word, just type it into the text box, and click the 
Add Words button or press ALT-A.  You can also paste in large 
amounts of text from any other source to learn large numbers of new 
words at once. 
 
To remove a word, highlight it in the list and click the Remove button or 
press ALT-V.  You can also highlight multiple words by using the 
CTRL key when clicking on words. 


